Vintage Drum Forum the best vintage drum forum on the Internet - Vintage Drum History - Vintage Drum Questions

Go Back   Vintage Drum Forum > Restoring Vintage Drums

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 10-23-2018, 10:02 PM
Drum Transit Drum Transit is offline
Member
 
Join Date: Oct 2018
Posts: 7
Default Ludwig 1123 (Spur-lok) spring action not working

Hi all,
I recently picked up two (what I'm pretty sure are) Ludwig 1123-1 hi-hat stands (Spur-lok plates, tripod, no tension adjustment). But I'm having problems with the spring action.

Both of them (one especially) needed a deep cleaning. Even after the cleaning, I'm getting the same problems. When I put on the top hat, it sinks. The spring action is also either very choppy or non-existent. Any tips?

Last week, I detached and removed everything. I soaked and cleaned the springs to where they looked great. I sprayed the springs and the lower tubes of each stand with all-purpose lubricant, replaced the washers, and reassembled. I tried both of them out soon after and they had nice, smooth spring action for the brief time I tested.

But I played them a few days later and they still don't work right with same issues as before.

Do I need to spray more lubricant? Manually stretch the springs?

Thanks!
Reply With Quote
 

Tags
1123-1 , hi-hat , ludwig , spring , spur-lok

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:58 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Copyright 2009 VSDwebdesign